A quick note about running webflow behind a proxy

For various reasons we want to maintain strict control of the headers of our root domain and marketing has decided to host the site at the naked domain without www.

There are a few lessons learned over the last few hours:

Every domain you are proxying for needs to be in the sites enabled.

The DNS errors and warnings can seemingly be ignored.

You can skip the DNS configuration entirely it seems. (I’m not sure, you might have to configure one domain correctly at least once this would require more experimentation, however this seems like the best way to reduce the risk of duplicate content if you are proxying the content.

If you select a site as a primary domain all the other hosts/domains will redirect with a 301. This is great for SEO, but horrible for testing. You will want to use curl to test things out as your browser may well cache an incorrect 301 for months.

I wound up having to disable https to get it working. I’m not sure why, as that seems like it should have worked :confused:

Any suggestions for improvements would be welcome.

The following is the config I wound up using for ambassador:

apiVersion: v1
kind: Service
metadata:
annotations:
getambassador.io/config: |

apiVersion: ambassador/v1
kind: Mapping
name: webflow_mapping
prefix: /
host: example.com
service: http://proxy.webflow.com/
host_rewrite: example.com
creationTimestamp: “2020-04-20T02:00:27Z”
name: webflow
namespace: website
resourceVersion: “283764462”
selfLink: /api/v1/namespaces/website/services/webflow
uid: 0546a6d6-03fb-11e9-9f2c-42010a8001bd
spec:
clusterIP: 10.51.251.60
ports:

  • name: webflow
    port: 80
    protocol: TCP
    targetPort: 80
    sessionAffinity: None
    type: ClusterIP
    status:
    loadBalancer: {}

The yaml seemed to get butchered, but hopefully you can still read the important bits.