301 redirects with a wildcard

I’m facing some problems redirecting a url to a new one
the old one contains the wildcard %

so for example it’s:

both for the urls with and without the . (dot) at the end

I tried redirecting them both to “/es/blogs”
but it keeps redirecting me to the 404 utility page - I read here 301 redirects | Webflow University
that i should escape the wildcards by adding % in front of them in the old url, but it still cant seem to work if it’s: /es/blogs/banks-and-something-seomthing-something-ra%%20tios

So any help is greatly appreciated

In a wildcard redirect the hyphens also need to be escaped as %-.
I have not tried dealing with the %20 type of construction. If you’re trying to do an exact match you might try using a space or a + to see how the redirect handler processes it.

I tried escaping the hyphens as well as %- but it also didn’t work
As for the second point, you mean creating a different separate redirect to test if the problem is indeed from the %20?
seems like a good idea that I’ll try

If this one’s not working I wouldn’t make your adjustment a separate one, just adjust this one and republish.

Personally I’d try it with no escaped characters at all, using a + instead of the %20.
If that doesn’t work I’d try the same with a space instead of the + and see if the configurator works with that.
If that doesn’t work, try escaping all the hypens and the + as well

And if that doesn’t work, best to contact support, because the %20 is giving you issues in the redirect configuration.

This is becoming weirder, as i tried it such as:
“/es/blogs/banks-and-something-seomthing-something-ra” to redirect to something else, as maybe the problem is indeed from the %20tios - still redirected me to the 404 page

then tried it as “/es/blogs/banks%-and%-something%-seomthing%-something%-ra” to escape all the - , didn’t work as well

tried with only removing the % and keeping the 20, same result
and tried with the + instead of the %20, same result

is there a limit to the 301 redirects? As i’m currently using 55

First, just in case it’s relevant to your test, the middle something is misspelled.

Second, any time you’re testing redirects remember your browser caches them, so you need to test it from a different device like your phone, or you can open Chrome dev tools, go to the network tab and disable caching while dev tools is open.

There is no limit to the 301s.