Webflow still transcodes Mp4 to a webm that is twice the size of the original file ?!


About a year ago I talked to your support about an issue with video transcoding. If I upload 2mb Mp4 for a background video, webflow will create a webm version (a format that is intended to make mp4 videos smaller in filesize) around 1mb, increasing the filesize by 100%.

It would probably be very beneficial to address that?

Thank you

1 Like

Did you figure this out?

1 Like

You can try different encoding methods / settings on your end to see if you get different (better) results. If you can’t and size is important to you, upload your encoded files to a CDN or webhost and include them using custom code. Webflow’s background video component has no settings to effect quality.

Why not reveal video quality settings for the WebM conversion so they can be configured in Webflow? In terminal, it’s simple to customize these settings - takes minutes. There would be high value to this improvement now that Google ranks sites inclusive of LCP (largest contentful paint, or the time it takes for the largest above-fold image to load).

If using Webflow’s native upload tooling, can I upload a different WebM file to overwrite the one you autogenerate to improve on PageSpeed load time?

@lgermain - Webflow does not provide this option. You can always host your own assets somewhere else and use custom code to serve them up.

BTW: I’m not part of Webflow just a community leader in case you thought different.

Nope, still not resolved to this date :frowning: