Webflow.io still showing up after Disable subdomain is ON

Hello -

I am trying to determine why the https://brightsides-fabric-studio-template.webflow.io/ is showing up on Google search results (and erroring out) even after I have disabled the subdomain in the settings panel.

I am not seeing any search results of my primary domain: brightsidekc.com

Any guidance on this?

Thanks
Jess


Here is my site Read-Only: (https://www.brightsidekc.com/)
(how to share your site Read-Only link)

Webflow projects need to published or unpublished to affect the hosting infrastructure. What steps have you taken?

Jess, it will be in google SERPS for awhile.
Last I checked, enabling “disable subdomain indexing” also just sets the robots, txt, which means if Google has already indexed your site it, those pages will basically hang around forever.

You might be able to request a removal through GSC if you can validate site ownership through a META tag inclusion.

Another approach I use is to have a script that will add a noindex meta only to the webflow.io site.

You also may be able to just “kill” it, by changing the shortname of your site. Then the old webflow.io site will be gone and Webflow will eventually de-index it.

The hosted domain of brightsidekc.com is fully published.
I was publishing the subdomain in parallel for a bit too but had stopped doing just the other day.

It may just be a waiting game?

Thanks!

Thanks! I did request a page removal from GSC - but this is great context.

Seems like a waiting game for the most part on indexing correctly–