Webflow hosting issue with non www. domain name and with www. domain name

How to I access the .htaccess file as I wish to do a redirect of the non www version of the domain name to the www. version?

Or is there another way to sort out the domain name redirect?

I’m hosting the website with Webflow but the domain name resides elsewhere (names.co.uk).

At the moment I have to publish the website in two places - with www. and without www. so it works in both instances of how people will type the domain name in. I don’t really want to be having to publish the website in two places!

Webflow 301 Directs only work from what’s after the domain name.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

There is no .htaccess for you to manipulate. When you define www as the default domain Webflow handles the redirect for you. Review the documentation.

I have one entry in the hosting using the www. version.

I have set the two A records and the CNAME record in the DNS as per instructions.


Sorry but even reading the documentation I’m struggling to understand what I have missed to make the domain name without www. to work? It’s loading a 403 Forbidden page.

The A records should be using a host name value of @.

Some DNS hosting services prefer that you set the root domain (yourdomain.com) as the host instead of @. We recommend that you check the “Adding an A record” documentation of your DNS host. Check Updating DNS settings to find a list of registrars and links to their DNS setting documentation.

I’m with names.co.uk and there is no support article for them with Webflow. Their DNS doesn’t allow me to enter ‘@’. Would you have anything to further enlighten me on this please or what do I need to ask names.co.uk tech support just to be crystal clear?

Thank you.

Here is Webflow’s troubleshooting guide.

They indicate that if you can’t add your A records then you should look at moving DNS to a service that can. Personally I use Cloudflare for DNS as it is blazing fast. I don’t use Cloudflare web proxy service on Webflow sites, just using DNS passthrough. Cloudflare is free for this and can be set up quite easily.

I got in touch with names.co.uk tech support and they said:

“I have now added your requested records, some DNS systems will accept the @ symbol, the Namesco system requires this to be left blank instead, it works exactly the same and the DNS is now resolving.”

I had already tried this yesterday (before deleting the 2 A records today). I’m still getting the 403 Forbidden page when trying http://ukmedfreedom.org/

Is there something wrong with Webflow’s redirect not working properly considering the default domain is with www. ?

I have since added the root domain:

and now it’s all working!!

When I had done this at the start, Webflow showed publishing options for both the root domain and sub domain making it 2 websites to publish. For some reason it now only shows the sub domain to publish and therefore, correctly, one website to publish and it automatically does it for the root domain.