Video Background not playing

I’ve added background videos on the website but it only plays on the mobile version (and not on desktop)
The videos play when you press “toggle preview” but it doesn’t seem to work on the Published website.

Here’s my published version

Hey @Israel_Reyes, welcome to the Webflow community. First off, what a great looking website!

The video plays fine on Desktop on my end. I have looked at the published website on the current versions of Chrome, Brave and Firefox. Have you tried opening the website in a private window or in another browser?

Thank you! I got it from a template :slight_smile:
It might be just me then. I’m using chrome, went on incognito, tried Bing, but it still doesn’t play.

@Israel_Reyes have a look at the following thread.

Yep that fixed it for me. That would mean everyone would have to update their display settings then?

@Israel_Reyes that’s great to hear.

Well, I guess so. A solution involving a little bit of custom code could be using the media query prefers-reduced-motion. If a user has this setting enabled, show a dedicated Play video button. If disabled, hide the button and play the background video automatically.

I had the same issue and discovered it was hiding behind all the elements. If you set the Background Video element to relative and add 100/1000 Z-index to it and it will show.

1 Like

This worked for me. Had the same problem, the background video was not displaying. Tried to set width and height but didn’t work. Realised that its position is relative and the “Z index” might be the problem. Yes it was. Just set the index higher and should be good