Trouble with section linking on dynamic template page

Can someone please tell me what I have missed? I have a button called “Read More”(the brown one) that goes to a div block underneath(on the same page). Every time I click on it it just goes to the homepage instead of the actual section on the page.

Is this a glitch with a conditional visible element value?

Here is the link to try it out:

Here is the shared link:

I would just hard code it, but since it is in a template it would mess up all other pages.

Here is my public share link: LINK
(how to access public share link)


I just click the button and it goes down to the section, but i test it on the shared link, try to export again.


I took a look at your read-only link. I noticed that your Rich Text Element doesn’t have an ID. Try giving it an ID of “Description-Part-2”

Thanks Pixel Geek but if you look at the Rich Text Document one level higher you will see the div with the correct id. However I did try your method as a test and it still did not work. It still takes you to the homepage.

Can you please update your post with some more info? Things like screenshots allow everyone to help you faster.


Okay here are screencast links.

  1. This one shows the published site. Notice when hovering over the anchor button it has the incorrect url structure. In addition when you click the button it goes to the homepage vs. the correct anchor on the page.
  1. This one shows the preview mode. Notice when hovering over and clicking on the button it functions correctly. But when published it functions, incorrectly.

Any update here? This seems like it would be pretty simple to figure out unless it is a bug on your side with conditions or something. Either way I need this for my client!!

Hi @904TECHNOLOGY, I took a closer look and noticed that the button settings were not set to go to the section - i duplicated the site and was able to get it to work on my end.

Can you try updating the link settings and let me know if that resolves the issue?

Just updated with again using the suggestions via email, which was to change the description-part-2 to a “section” under the tag and I was still unable to get it to work when published.

Please help

Specifically you can test on this page

Would it have anything to do with me changing the Base Tag: (href=) so that all of my links would work with the idxco/mls wrapper?

Any updates? Still running into this issue and it seems like if I am running into it using the new collections/cms others will too.

Hi @904TECHNOLOGY, In my testing, I have been able to get the scrolling to work correctly. Could you please do me a favor and set your base Navigation-Holder div to have a tag of header? When using a fixed position navbar or navbar container, you also need one header on the page.

That should solve the scrolling alignment issues, and in my test, scrolling worked correctly on both the home page and the lifestyle/marsh-landing page.

Once you set that style, republish the site and let me know and I will take another look :wink:

Sorry for the late reply. Still having this issue. I have even cleared cache and cookies/tested on other browsers. Please go to and hit the read more button. You will see it goes to the homepage and then scrolls down :<

Any update here? Been waiting to launch…

Going on 27 days and there is still no answer. As a result i am having to remove this option. Webflow staff please look at a backup copy prior to Tuesday 10:30pm, February 2nd to keep investigating. …

Good to close this. I found a workaround