Streaming live at 10am (PST)

Trouble loading images not set to publish over SSL

I am having problems with browsers blocking images from just one of my sites.
It was working fine and then I have to replace some tabs, add images and reorganize the content.
For some reason the Chrome and Firefox see the images as unsafe content and blocks them.
I could just go to settings and allow the content to be displayed but this is going to happen in other users browsers too, which is a big problem.
When I use the images as background (like in the tabs on the left-minerals page) they show up fine.

here is what i see on chrome:

here is the site www.investmentsfromearth.com

and the design view link
https://preview.webflow.com/preview/investments-from-earth?preview=bf2da133620cee81269547d8ee9e68c5

I have no clue how to fix this.

Does anyone know?

Thank you
Lilian

Hi,

Could you check to make sure that Publish images using SSL CDN is enabled in your project settings under the Hosting tab. Remember to also republish your site.

oh great!! it worked! thank you so much.
I was starting to think i did something wrong. I am still a newbie in webflow and I am so happy the forum is helpful.

Should I turn it on for all sites?

thanks
Lilian

No worries. If you’re enabling SSL for your sites, the Publish Images using SSL CDN option should enable automatically, as it needs to be enabled to prevent those mixed content errors from occuring.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.