Trouble Binding a rich text element to a CMS Rich Text Field

I have recently started using the webflow CMS for our blog. I went through the usual issues and found the usual answers on this forum (Shout out to all of the contributors for all of those answers! You saved me many hours of frustration).

I have everything ready to go except for one issue. I can’t seem to bind the rich text element on the page to the rich text field in the CMS. I understand that I to bind an element to a CMS field, both must be the same type (image to image, plain text to plain text, rich text to rich text, etc.). As I understand it, this is what I have done and I have had no issues binding other items. I must be doing something incorrectly because no option to bind the rich text element appears.

I’m using the standard blog post template (with additions of alt text for ADA compliance). The field Post Body is set up as Rich Text. Here is a screenshot of my Blog Post Collection Settings:

Here is a screenshot of the page with the rich text element and sadly, no top to bind it (link to the read-only page below):

Any insight into what I’m doing wrong would be appreciated.


Here is my public share link:

Hi Niles, click the purple dot in the corner.
Purple is Webflow’s visual cue for data-binding related controls.


Thanks again, Michael! I wasn’t ready for that UI Curveball. I was expecting a checkbox as is done with binding other CMS elements.

This was exactly what I needed.