Streaming live at 10am (PST)

This webpage is using significant memory. Closing it may improve the responsiveness of your Mac

I just got the new m1 MacBook (16gb) and Webflow doesn’t play nice with it.

This is the first time I run Webflow on a laptop and am surprised to see it works so poorly.

Not only does it drain the battery significantly (which is the minor issue here), I keep seeing the message “this webpage is using significant memory. Closing it may improve the responsiveness of your Mac.” on my safari.

I have no other extensions, and seems like I’m not the only one experiencing the issue.

it’s really frustrating. It makes it so I’m unable to work on my website from my laptop. My browser keeps crashing and the only solution is refresh and work for another 10 minutes or so, until the error reappears.

Really frustrating. Has anyone else experienced this issue?

Did you try chrome browser?

I’d rather not install it, to be honest. I don’t like Google products and Chrome would clutter my computer.

You might consider MS Edge it is optimized for M1 and because it used the open source chromium project it should work fine with Webflow’s designer. Deleting an app on OS X is as simple as deleting it. This is an option or you can just wait for Safari issues to resolve themselves possibly when a future release happens. I would not count on Webflow to make any changes to the designer for your use case issues. Hope it works out for you.

hi @Daniel_Alter yes id do, but it is just informational msg. You will get this msg even when you open FB or website with 3D animation or with heavy 2D animations. You can just ignore and close this msg.

this is part of answer on internet just browse it and you will find many articles with similar content :wink:

Well, first of all, this is simply a warning that the site is possibly causing Safari to use up a lot of RAM. That may be quite normal behaviour, since it may be that Safari is using the RAM as cache to speed up the performance of the website. I mean maybe it just has a lot of video content or something of the sort. A lot of dynamically updating content could cause the same issue I suppose. So one thing to do is to check to see if it is really true that Safari is using a lot of RAM. Remember, it is not necessarily a bad thing if you are not experiencing any sluggishness in the performance of your Mac. If you’re not experiencing any problems then you may be able just to ignore the warning - that might be the best thing to do.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.