Slider does not work when the site is published / But if you refresh

Hello, I need help.
Slider does not work when the site is published.
But if you refresh the page everything starts working.

Here is my site Read-Only:
([how to share your site Read-Only link][2])

You meant the first section of your site ? Is this supposed to be multiple slides ? I only see 1, now navigation arrow, even after refreshing.

I mean this section

There is Autoplay, but it turns on if you refresh the page twice

Your slider is set to 1000ms delay, try lowering it to see if it changes anything, I tried 500 and I could see the slides play.

Unfortunately, after clicking the publish button and go to the site, it does not work. But as soon as you refresh the page a second time, the problem is solved (

hey @ruslan.dzhabiev how did you solve this problem? could you please let me know as im facing the same issue. The slider navs only appear after i refresh the page. Thanks in advance.

I am also having this problem will all the sliders on my website. If you refresh the page they work, but unfortunately new visitors to the site aren’t going to know to do this. Is this a bug in Webflow? Is Webflow working on a fix?