Safari issue loading certain elements (purchased template)

Hi there,

I have reached out to support and the original developer of the theme already but unfortunately haven’t been able to get much of a response. Support advised that I contact the developer of the theme. And they did not reply unfortunately.

I’ve noticed an issue with my site not loading certain sections correctly in Safari on a mac. I’ve viewed the original theme in Safari to ensure it’s correct in thinking that it’s within the theme itself, and not anything to do with anything I’ve altered in the theme.

Here’s the website in Safari with the issues: Dropbox - FounderX Website Issues Safari.mp4 - Simplify your life

Here’s a version of the website in Google Chrome displaying correctly: Dropbox - FounderX Website Issue Working.mp4 - Simplify your life

Here is my site Read-Only: Webflow - FounderX MASTER

Password is “12345”

The theme purchased was “Conceptualize”: Conceptualize - Portfolio HTML5 Responsive Website Template

Thanks a lot for any support, it’s much appreciated.


this looks strange. The site seem to work fine in both Chrome and Firefox. Can you check the console in Safari and see if any error messages appear?

Sure I’ll check the console in Safari and post the response - thank you.

There was 1 error that was showing up as far as I could see - I’ve included a couple of screengrabs.

I can copy and paste any of the code if that’s helpful too.

Cheers for your response again.


so that looks a bit strange but seems to be related to Webflow’s internal Javascript file which (hopefully) shouldn’t be the issue.

I looked through the interactions, and what I can see is that some interactions (for example “IMG Overlay Load !.9”) are set as “When scrolled into view” interactions, instead of a “Page load interaction” when they in fact should be played on page load.

Try to swap “IMG Overlay Load !.9” to a page load interaction, publish the site and let me know what happens.

Thanks for that - I’ll try changing the interaction on one of the elements and let you know :slight_smile:

Looks like that solved the issue, I’ll just go through all the interactions manually and adjust them. I don’t suppose you’ve got any thoughts as to why the services tabs aren’t showing up in Safari either? I’ve testing in Safari 12.1.2 - works fine in Chrome and Firefox.

Cheers again - the helps much appreciated

That’s great.

The second problem is also strange, there seems to have been bugs with the dropdowns and positioning of elements in Safari before but since I run Windows I can’t really troubleshoot it with newer versions of Safari.

Are the dropdowns coming from the template or added by you? In case it’s the former and the template is old, maybe they were developed when Webflow had bugs and some strange things are happening there.

Try to recreate them with a new dropdown element & new classes, publish and see if it solves the problem.

No problem thanks for that - the dropdown wasn’t in the theme originally, I made this with the pre built sections in Webflow, thanks a lot I’ll give that a go