Streaming live at 10am (PST)

[Resolved] Is the "stage for publish" and "draft" button working?

I currently find that in collection panel. if you select a draft item. there will be a “stage for publish” button on the top. and if you select a non-draft item. then the button become “draft” . but i just tried and it failed. … what happened?

Thank you for taking the time to report this, it definitely seems like odd behavior.

To help us locate and reproduce the issue on our end faster, we would appreciate if you can provide additional details:

  • Which date did you first notice the issue?

  • Please describe the steps taken leading up to the issue occurring

  • Upload screenshots/screencast videos displaying the issue

  • Please share your project’s Read-Only link AND live site’s Published link:

    • The read-only link is a special url generated in the Dashboard to allow others to view your project in the Webflow Designer. How to get your project’s read-only link?

    • The published link is the subdomain where you can view the live site with any custom code running. It is important to share this link, as custom code does not run in the Designer.

  • Please also let us know what browser version you’re using by visiting and copying the share link here:


Can you also please try the following:

  1. Try to see if the issue happens while being logged into Webflow using your browser’s Incognito Mode/Private Browsing with all plugins/extensions turned off, so that we can rule out a third-party conflict.

    How to start Incognito Mode/Private Browsing:

  2. If the issue still persists, open the browser’s developer console on the page where the issue occurs, take a screenshot, and upload it here as well.

    How to open the console:

Critical or very urgent issue?

If your issue is critical or very urgent, please also email Webflow support at as Webflow staff prioritizes email support over forum support. Include this forum topic’s URL in your email so they can also update the rest of us on the issue and close this topic once it is resolved.

I have the same problem. Webflow is not publishing drafted posts to the live site.

This is the same issue I reported here.

Still having this issues 3 days later. It appears that it is the Designer and Editor that are freezing up and not the browsers. After a short time Chrome will ask to kill the page and Safari will automatically reload the page for using to many resources. The fans on my MacBook Pro kick on and all 4 cores run hot.

Thanks @adollei, @Ryder_Meehan, and @matthewpmunger for informing us of this issue. We’re working on making sure you can still save an item as a draft even if there is an empty required field. We’ll let you know when the fix gets pushed!

1 Like

Hi @matthewpmunger I’m looking into this issue now and will be creating a bug report for this.

Once I have an update, I’ll reply back immediately.

thank you for your patience.

1 Like

Hi @matthewpmunger

I wasn’t able to reproduce the issue on a cloned copy of your site.

​Can you please try the following:
(1) Try to reproduce the error while being logged into Webflow using Incognito mode:
(2) If the problem persists, please take a screenshot of your Console and send it to me:

If you’ve already tried this, I’m happy to get on a screenshare call with you to see the bug occur.

I’ll be standing by for your response.

Hey @PixelGeek

The issue happens when I go to the “Content” collection. Tried Incognito mode and Private mode (Safari).
In Chrome it froze up WHILE trying to select an option from the first Ref Collection.
In Safari it froze up AFTER selection an option from the first Ref Collection.



Here is the console shot from Chrome.


thanks for that screenshot. Yup. My Macbook’s fan was going crazy after clicking on that Kingdomino podcast and my Chrome browser froze.

I’ll report this immediately to the team.

If you run into this issue again and want to close that browser tab, you can click on window then task manager, then click on browser tab that is causing the issue, then click end process

I’ll reply back with updates as I get them.

@adollei and @Ryder_Meehan We think your issue was because we were checking validation on fields, even though you were saving it as a draft. We just fixed that. Can you check to make sure it’s working on your projects?

1 Like

I am having the same issue… I can’t seem to get any of my CMS items to “publish” - can only “Save as draft”

Hi @wethebirds,

We do restrict some items from publishing. Was the publish button disabled or did you get a failure modal when you tried to publish?

If you can send me your [Read-only link](http://How to get your project’s read-only link?) and which item you were trying to publish, I can take a look.

Somehow it works now. I don’t know if that is because the new collection publish button or other reason. I will continue watch if this will happen again.
btw. since collections can directly publish. why we don’t have a button for batch publish?

Simply nothing happens. Its only happening on one particular blog post.

Here is my read-only link:

Collection: Blog posts
“The Facial at Enlighten”

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.