Redirect Problems

Greetings! I’m running into an issue I need to fix asap. I created a new website in WF for a company who’s old website was made in Wordpress. No one knew the login to the registrar so I had to create a new domain, and was able to create a redirect with a wordpress plugin to the new website. The old wordpress account has been cancelled so now entering the old domain simply gives an error page saying the site cannot be reached.

I’ve been able to gain access to the domain registrar, webhost4life, and have been trying to create a redirect from the hosting settings but it never works. Their support is composed of chatbots that always promise it’ll work in 20-30 minutes but it never does. Emailing them results in an automated reply telling me to talk to the chatbots.

Is there some other way I can redirect the domain? I’ve tried adding a 2nd domain in the WF Publishing settings and adding the DNS records to the old domain but that doesn’t work I’ve since learned. Is there anything I can do to connect the original domain to the new site and have it redirect all within webflow?

Any advice would be appreciated thanks!


Read only link:

This is the easiest approach.

I’m guessing your Webflow site is at, and your old WordPress domain is at

You’d add exactly the same DNS records to, and then add that name to your custom domains list on your Webflow site.

Once it connects properly, you can make the default domain if you want.

Make sure to republish after you reconfigure your domains.

Note- you cannot control redirects separately for two different domains this way, so if you have a lot of old WP links in the wild, you may want to beef up your 404 page to help people find what they’re looking for. It will get a lot of love.

One final add- some WP hosting providers seem to bind the DNS configurator to the hosting plan under a cpanel setup. It’s ugly and difficult to separate. If you cannot figure out how to set your DNS settings, one option is to setup a free Cloudflare DNS, and point your nameservers there.

Hi Michael, thank you for replying. That is correct, is the original URL. I did try this at first and it wouldn’t connect to the domain, but I never set that as the default domain. If I go in and do this again, and set it as the default do you think that would that allow it to connect properly?

As long as you have the DNS setup properly it will connect and both will work.

The default domain is more important for Webflow’s side of things.
It’s important, but you’d see a successful connection regardless.

Okay thanks I’ll try it again. One more thing, do you recommend deleting the old DNS records to the previous site it was connected to?

You absolutely must delete any other A records, or www CNAMEs.
Other records TXT, MX… depends on what else you’re using that domain for like email.