Streaming live at 10am (PST)

Problem with Tabs after exporting HTML

Hi guys!

I can not say for sure when there was a problem because 2 days ago I added a new section with tabs to the site. Before that, I did not use the tabs on this site.

When publishing the site, the tabs (language selection) in the “Documentation” section work correctly.

The problem with tabs after exporting the site is in the “Documentation” section - nothing happens by clicking on the tab button.

How can I make tabs work after exporting HTML code?


Read-Only link:

Published link:

Exported HTML site:


Thank you for taking the time to report this, it definitely seems like odd behavior.

To help Webflow staff locate and reproduce the issue on their end faster, they would appreciate if you can provide additional details:

  • Which date did you first notice the issue?

  • Please describe the steps taken leading up to the issue occurring

  • Upload screenshots/screencast videos displaying the issue

  • Please share your project’s Read-Only link AND live site’s Published link:

    • The read-only link is a special url generated in the Dashboard to allow others to view your project in the Webflow Designer. How to get your project’s read-only link?

    • The published link is the subdomain where you can view the live site with any custom code running. It is important to share this link, as custom code does not run in the Designer.

  • Please also let us know what browser version you’re using by visiting and copying the share link here:


Can you also please try the following:

  1. Try to see if the issue happens while being logged into Webflow using your browser’s Incognito Mode/Private Browsing with all plugins/extensions turned off, so that we can rule out a third-party conflict.

    How to start Incognito Mode/Private Browsing:

  2. If the issue still persists, open the browser’s developer console on the page where the issue occurs, take a screenshot, and upload it here as well.

    How to open the console:

Critical or very urgent issue?

If your issue is critical or very urgent, please also email Webflow support at as Webflow staff prioritizes email support over forum support. Include this forum topic’s URL in your email so they can also update the rest of us on the issue and close this topic once it is resolved.

Thank you for responding quickly.
I added information to my report about the problem.

@cyberdave @waldo

Hi @Denis_Martemyanov thank you so much for sharing this!

That definitely looks like odd behavior occurring on your externally hosted site.

I just performed a test on my end of exporting a duplicate of your site and the tabs were working as expected:

Could you please try logging out and back in to your Webflow account and performing a fresh site export to see if that resolves the issue? :bowing_man:

Thank you so much for helping us find the cause of the problem.
With exports from Webflow, everything is fine.

The problem was :drum: in Cloudflare! - this service removed part of the JS code. I had to spend time looking for a reason, but the problem was successfully solved! :tada:

If someone has a similar problem with using Cloudflare – go to “Speed” –> “Auto Minify” and set “yes” for JavaScript and HTML.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.