Problem with Slider in Accordion

Hi everyone!

I don’t know if it really is a bug, but it really looks like one…

I have a slider inside an accordion (only in the first title “United State of America”). But it doesn’t seem to work, it only shows the first picture as if there was only one. But the weird part is that it starts to work when I resize the window… :man_shrugging:

Quick video to explain : https://www.loom.com/share/133ba5bbf0564631868f12b4e1800b3c

Thanks for the help in advance! :slight_smile:


Here is my site Read-Only: https://preview.webflow.com/preview/corentinbureau?utm_source=corentinbureau&preview=1fd9e4c18ff310eb09aefc3bd2322f9c

1 Like

I think it’s because of the accordion interaction because it works when I disable it, but I can’t find a solution to make it work with the interaction… :confused:

Hello everyone :slight_smile:

Does anyone have a solution for this ?
I tried different things but no luck so far…

Thanks!

Hello @Corentin_Bureau,

I tried a lot of things but I couldn’t find a solution for your problem. I seems to be a glitch. Now, one thing i didn’t try that could work for you, that helped me in the past, is to delete your current accordion and build it again. I know it seems pointless but in the past it had worked for me on different projects with similar set ups. If that doesn’t work, try contacting support at webflow.com they can find a definite answer for your problem.

Thanks! I’ll try that and see if it works!

Hi Pablo,

Your technique helped me understand what was the problem! It was because of width settings in the accordion interaction that were messing with the slider! Seams to be working now :crossed_fingers:

1 Like

@Corentin_Bureau,
Awesome, I’m glad it worked out for you. That technique, although time consuming, helps a lot, specially since when you are rebuilding something that didn’t work before, you have a different mindset, and that makes you avoid the mistake that cause the problem in the first place.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.