Streaming live at 10am (PST)

Open Graph Image does not show up on social media posts

Despite having added an open graph image link to the photo I want to appear when a blog entry, the image does not appear.

What am I doing wrong?

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hey @officeaccord,

For open graph on CMS items, you still need to set it in the page settings. If you look at the page settings on any CMS page template, it gives you options to direct inputs to fields in your CMS list.

I would recommend adding an image field specific to open graph to your CMS list, and then just upload the open graph image with the CMS item rather than to the assets. For your open graph image Webflow provides you with a drop down in the page settings which allows you to select an image from the CMS.

Hopefully that helps.


Thanks for your assistance with this, Andrew. Still no luck getting the image to appear in social media posts.

These were the steps I performed.

Hey @officeaccord,

You are missing the step of assigning the open graph image to that field. Can you share the read only link? I can do a screen record and show you where to do it.


Are a life savor!



Here you go.

Since it is a read-only link, it doesn’t actually let me click the drop down to select the photo, but I gave it a pretty good emphasis with the mouse. You’ll notice when I confirm ‘View Only Mode’ on any of the boxes a purple +Add Field clickable text appears. Those should already be there for you. I clicked one to show that you can link it to any field in your CMS that’s format fits a text box. Not a bad idea to add open graph title and meta to your cms list so that it automatically references all of that info for each blog post you make.


Thank you so much, Andrew!

Amazing support