Streaming live at 10am (PST)

NUMERIC input field not working on phone

I must get certain input fields to display only NUMERIC PAD inputs on mobile devices (remove QWERTY and display only 1234567890)



Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Wow… I found this via search just 11 minutes after you posted it. I’m trying to get phone numbers to work, but they are allowing text to pass through. Maybe there’s a bug in the programming? @Waldo

1 Like

Hi @miekwave @scottiejhaines

I did some testing on this end. It looks like the text type: number prompted the secondary keyboard view with numbers and symbols, while the text type: phone showed the number only keypad. Here’s a quick recording showing how this looks on my end:

If you need to only display the numeric pad, can you try using the phone type to see if that helps?

1 Like

What I was getting at was that I can type in text in a phone field and it allows it as a valid answer (desktop). Maybe that’s different than miekwave’s problem.

I need to make certain fields custom attribute

but getting “this is reserved name” error.

How can I do this without custom code?

Hi @miekwave

That’s because this attribute is a reserved one — you should be able to use the number or phone option from the text type dropdown. In the link above, I show that using the Phone text type will prompt the number only pad.

@scottiejhaines we don’t currently have a way to enforce certain formats outside of the email address field.

But we can definitely add that as an enhancement request if you want to create a new Wishlist item for it :slight_smile:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.