Navbar Dropdown Won't Stay Open

Hello,

I have created a Navbar using the default navbar and have added some drop downs and customized them to be the full viewport width. The drop downs are set to hover. My problem is that when I move the mouse out of the dropdown item and into the dropdown list, the menu closes. I’ve tried experimenting with some close delay and the z-index, but that neither seem to help.

Thanks in advance for your help.

UPDATE: Since posting this and going to the preview, I’ve noticed that the menu no longer opens on hover. I’m not sure why, but it only seems to work on click now.


Here is my site Read-Only: Webflow - Millersburg Christian Church

Hy, I have the same issue as of today. Navbar menu doesn’t open on hover anymore. It worked yesterday and I haven’t made any changes on the navbar.

Yes, same here - just started today. And the weird thing is, the other problem I was having (with the popup not staying open), seems to have gone away. Not sure if this is a bug or a fix?

Hey Steve!
I checked your preview link, the dropdown on the mobile breakpoints seems to work fine, but there’s no hover action. Usually hover makes only sense for non-touch inputs, why would you want a hover interaction on a dropdown that most likely only shows on tablets and smaller?

kind regards

Hi, thank you for your reply. I’m not sure I was clear enough in my original post. I’m not referring to the mobile dropdown. I actually have dropdown buttons in the navbar itself that I want to activate on hover on the desktop. I didn’t use an action to achieve this (although I’m not wondering if I should?). Instead, I used the dropdown element and chose the “open menu on hover” option in the element settings.

I’ve attached a screenshot to clarify.

My initial problem was that the dropdown would disappear when I would move my mouse down into the dropdown area. However, that problem seemed to disappear this morning, however the hover doesn’t seem to work anymore. I hope I’m making sense. Thanks again.

okay, so the hover function is working again on my navbar.

It is now working on mine, as well, and my issue with the dropdown staying open seems to have resolved, as well. I wish I could tell everyone what I did, but it seems to have fixed itself.

I noticed the currently shared preview has no animation set on the dropdown opens interaction?

image

Also there were no previously created ones to choose from. Maybe you unassigned them and then cleared the unused?