Nav bar is going crazy

Hey guys,

I’m completely stumped and have tried everything at this point to resolve this but couldn’t figure it out. Please have a look at read only link below. I’m animating the nav bar (which is a symbol) on a page load animation. Two problems are occuring:

  1. If I set the nav bar initial “move” state to -100% (y-axis) and then move it to 0% (y-axis) and play the animation, the animation doesn’t play out and the nav bar just sort of appears at the 0% position

  2. If you scroll all the way to the end of the page and scroll all the way back up to the top, the nav bar disappears (unless you hover over the invisible drop downs, then it shows up)

What is going on? It seems like a glitch to me at this point. Any ideas?

I thought it might be a browser rendering issue on my end. Can someone confirm if this is happening on their side?

I thought it might be a symbol problem. I unlinked symbol and ran into the same issues.

I tried making a new nav bar.

I’m out of ideas. Please advise.

Thank you.


Read only link: Webflow - Endeavor 3D

Published page: Industries

hi @Mack_BA on my side nav animation works. The only thing I found is strange gap and different styling compare to WF designer preview. There is an error you should fix first and then see what next have to be done.

Good practice to be able check live site for its bahaviour is to share also link to published site so people do not need to rip it of from read-only link :wink:

NAV IN ACTION

ERROR

GAP NO STYLE

Hey Stan -

Good point! Here’s the link to the published site: Industries

The problem I’m having with nav bar is it disappears when I scroll all the way to the bottom and then back up to the top again. You can see it happening in this video: Loom | Free Screen & Video Recording Software

(side note: I’ve since added splitText to the website but this problem was happening before any custom javascript code so it’s not related)

HI @Mack_BA I can’t replicate issue you have. Here is the video what I see in all major browsers.

Thanks man. It could be a rendering issue with my laptop, although I’ve never had that before. I tried it on another computer too and had the same issue. Not sure. I appreciate you recording that. I’m still seeing it on my end but I’ll just keep pushing along.

1 Like

hi @Mack_BA if this happened only on this specific page the first thing I will try will be remove second animation to see what happened mean if issue persist. But like I have said I do not see any issue on my side.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.