Multi-reference field not displaying in CMS options

Hi all!

I have been trying to do this for hours and nothing is working. On the top you can see I linked a blog post Collections and then under my animation I linked the multi-reference from that blog post and it worked (somehow because I can’t figure out how to do it again or why it let me reference two different parts of the collections in the first place).


you can see it even let me reference two parts of the collections (the “use this for practice” and “multi-reference”

Now I am trying to recreate this at the bottom to fix a different bug that was happening in the first one but now the dropdown does not show multi-reference field at all. I’ve tried on multiple different blog posts and pages and nothing works. Please please help!! I’ve been trying at this for so long.

Here is my public share link: https://preview.webflow.com/preview/cleatstreet-14d238d93153c3ed320bb3d4033?utm_medium=preview_link&utm_source=designer&utm_content=cleatstreet-14d238d93153c3ed320bb3d4033&preview=2c958336fb43a99b4a4b63fbbb100044&pageId=5fd8feb8ad191646b2c48b9d&mode=preview

Thank you!
Summer

Hi @summerslough! I think the issue is that you can’t have more than one nested Collection List on a given page.

In your top example, the outer Collection List references the blog posts, and each item in that list contains another Collection List that references the “multi reference” field for each given blog post. To be able to do that below, you’d need to put another Collection List inside of the current Collection List that has “Use this for practices” as its Source, but you can’t have another nested Collection List on that page since there’s one above.

Does that make sense?

Ahhh yess thank you so much!! Do you also happen to know why the animation works perfect for the right image and bottom two (where it just pushes everything else on the page down) but when you click the animation for the top left image, it pushes all the other ones around on the page in a jumbled order.

Thanks in advance!

I’m glad that helped! For the animation - is that on the same page or a different page? I’m having trouble finding an animation on that same page.

Seems like it got deleted somehow but I just added the animation back! When I click the top left animation “betting basics” it moves the other content around the page randomly, but when I click the “getting the best lines” on the right or any of the bottom two, it moves everything below it downwards which is what I want. I’m not sure why only one of them doesn’t act like the other three.

Any luck on this? I still haven’t been able to find a solution.

Thanks in advance!

I think I found a fix!

It looks like the issue has to do with the way the “2 columns” layout setting works on the Collection List.

First, set your “Collection List 9” class to “Full Width” under Collection List Settings.
CleanShot 2020-12-21 at 19.21.56@2x

Next, set the display for “Collection List 9” to grid with 2 columns, you should get the desired result.

I hope that helps!

Thank you so much that worked!!!

1 Like