Streaming live at 10am (PST)

M.domain troubles

Hi guys,

I need some help!

A website I have created for a client, www.youlittlebeauty.net.

When the business name and location is punched into Google on a mobile phone (you little beauty ballarat) it brings up the link to the website† as m.youlittlebeauty.net. When you click on this link it says: Safari cannot open this page because the server cannot be found.

I am hosting the site and did a little Googling. I created a m. subdomain and included the exported web files in there and when you manually type in m.youlittlebeauty.net it loads perfectly, but that obviously isn’t how this works - it’s the link from Google that isn’t working!

Frustration setting in :expressionless: looking forward to hearing from someone soon!!!

Thanks in advance!
Melissa

Hi guys,

I have exported the code again and relaunched! AND it worked! I have no idea what the glitch was but if anyone knows I’d be interested to know.

Thanks
Melissa

I was looking into the issues with the 1st message - and was writing a reply - when I saw your 2nd message :blush:

Glad it worked out…

Question: why do you still need the 3rd level domain (the m.) ???

Webflow is responsive - and (I checked) it works on an iphone / ipad… with the main domain (www.littlebeauty,net)

When I google “you little beauty ballarat”… I don’t get the m.domain.

When I google “you little beauty”… that’s where it appears. So it’s definately index.

Perhaps - consider putting a permanent redirect of m. to the main website.

I have my own dedicated servers - and don’t use Google… but you should be able to do this in your google control panel.

Hi Revolution,
Thanks for your response and apologies for my delayed response.
I didn’t setup an m. domain (as you said Webflow doesn’t need it). For some reason when someone searched for the business on a mobile it automatically listed it as an m.domain in Google. I have no idea why it did that! I actually set the m.domain up afterwards and tried to do a redirect with no luck . . . thankfully the full site re-load worked but I am none the wiser!!! :stuck_out_tongue_winking_eye:
Melissa