Streaming live at 10am (PST)

Link Block is always opening NEW Tab

Hi there,

I have a Link Block, I am sure that (open in new tab) is not checked (In Link Setting)
However it is still opening the Linked page in NEW tab
I don’t want it to open new tab.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Try creating a new Link block element applay your styling and move yoy child element to the new link block

Thank You for replying … But its still not workin
I am trying to do Link Button Instead of Link Block.

Can you pls add your share link

This is my project
https://preview.webflow.com/preview/test-of-naf?utm_source=test-of-naf&preview=0dc32e66d343b5d5012faf758acd150f

In (Our Products) Page you will find 2 groups of links
the first 4, these are i created with normal Link Button
the second 4, these are the old ones (with Link Block) that Insisting to open new tab.

In Preview Mode it looks great.
But when i upload it to the hosting space it will start opening new tab
You can check this Link:
http://naimabdallah.com/index.html

OK i can se your problem. Everyting looks ok. Since i cab’t change your project can you try following.

Can you create a brand new Link block Then copy the Design Jet to that livk block.
then try again, if it works add your class DesignJet Block Link to the new Link block and try again.

Im not sure it will work but give it a try.

1 Like

I tried that …
But let me try again & i’ll let you know.

Thank you for your time

Now It works …
But what can i understand from this??
I mean what is the reason??
Once i have to redo all the page Items, What was my mistake??

I’m not sure you made any misstake. I think is a BUG. I have experied similair things with another elements when i have been doing alot of changes tot it. Will report this as a BUG.

1 Like

Has anybody found a solution for this yet?

It only seems to be happening with external links (page links work). I’m using a text link and have tried deleting and remaking the buttons but it is still happening… I’ve tried different types of button and links and link blocks and they’re all doing the same!

From what I gather off other forum posts this seems to be a Webflow bug… but I really need a fix asap!

1 Like

Can someone from Webflow Support answer this??
I cant have multiple windows opening the same link which I buttons to throughout my website… There needs to be an option that if the user has already opened the link in a new window that if they open the same link again it focusses to the existing window in their browser.
Please help.
Thanks in advance

Im having the SAME ISSUE 3-YEARS LATER. Why wont Webflow support reply? OR fix the issue after 3 years!

Hey @kinsfather

I notice that there are different issues referenced in the previous thread replies. Could you please be specific about what your experiencing and follow the instructions below. That way we can understand what’s going on.

To help us locate and reproduce the issue on our end faster, we would appreciate if you can provide additional details:

  • Upload screenshots/screencast videos displaying the issue

  • Please share your project’s Read-Only link AND live site’s Published link:

    • The read-only link is a special url generated in the Dashboard to allow others to view your project in the Webflow Designer. How to get your project’s read-only link?

    • The published link is the webflow.io subdomain where you can view the live site with any custom code running. It is important to share this link, as custom code does not run in the Designer.


Thanks in advance!

1 Like

READ ONLY LINK: Webflow - Kinsfather Studios

PUBLISHED LINK: Equipment - Kinsfather Studios

SCREENSHOTS VERIFYING LINK IS SET TO “OPEN IN THIS TAB”:
Screen Shot 2021-09-02 at 6.35.00 PM

Thank you for the links and screenshot. After testing in different browsers, the button is opening in this tab. Looking at the url, it appears to be targeting a section on the homepage. If so then it’s best to use a relative url which omits the base par of the url. Using /#Studios in the URL setting instead of https://kinsfatherstudios.com/#studios. This is what the native Webflow link type of section does which I see is in use on the symbol overrides on the homepage. (see screenshot below)

CleanShot 2021-09-03 at 09.40.55@2x

In the relative url /#Studios the / redirects to the homepage of the site and #Studios targets the element ID for that section on the homepage.

If this is not what you’re trying to achieve, please explain the desired outcome, and I’ll do my best to help you work towards that. Hope this helps.

The desired outcome is for the page to in this tab navigate to the home page to the section specified in the #studios of the URL. There is nothing in Webflow’s documentation that states that if you specify a section of a page in the URL that it forces open a new tab despite the specified in this tab

Please let me know how to achieve this as Im certain Webflow would have a disclaimer on their support pages (which are EXCELLENT) if this was something not possible despite the settings selected.

I’ve got the same problem. Even happens when linking to an internal Page. Seems like a bug that must not be overly hard to fix?

If a Webflow support person is willing to help I’d like to share the link in private for Webflow folks to take a look. Thanks!

@kinsfather and @RuudNL let’s get this solved for you.

This seems like it might be a technical issue, and we’re here to help. It is likely we’ll need to investigate and discuss your private account details. Could you please contact our Customer Support Team at support@webflow.com?

One of our Customer Support Team Specialists will be able to investigate and respond via email! Thank you so much!

1 Like

I’ve emailed Webflow Support as instructed.

1 Like