Intercom not showing up

I added the custom code for a widget, but it’s not showing up. Any ideas? Worked fine on my other sites

Here is my site Read-Only: [LINK](Webflow - Scout)
(how to share your site Read-Only link)

Just open your console and you will see the error:

   This domain is not allowed for the Intercom Messenger. Add your domain here:

@ColinKeeley - you have a console error:

"type": "error.list",
"request_id": "000ts5ioldon44jogcc0",
"errors": [
"code": "client_error",
"message": "An app_id parameter must be specified"

Are you sure you’ve copied the embed settings correctly?

Actually, @pietrofalco is probably correct in this case.

This was it. Thank you!!