Streaming live at 10am (PST)

Interactions 2.0: This element does not exist on this page

My question: How do you permanently relink to an element?

I keep getting the red warning triangle on parts of my interactions saying that elements are missing after I reopen my site in the designer, which is weird, because they aren’t missing. They’re right there in the document.


The message says “This element does not exist on this page. Please replace this item with a new target.” Ok, but how? I see that you can temporarily replace an item by selecting a class from a pull down, but this seems like temporary a stand-in. The red triangle still remains in the interaction.


I keep getting the same error - following the tutorial on show and hide navbar on scroll. Works fine and then after preview I get this error again. Would love to see a solution to this.

Yeah, I had this happen when adding an interaction to an element, then kept the interaction, but deleted the element. IX2 is having an issue with this. You need to delete the interaction from my experience, and add it again. Not sure what the best fix is yet. Please contact support directly, this is a known issue that I believe has been presented to development over that last week or two.

They posted a fix, try this:

Not resolved my issue. The navbar hide animation works fine and even publishes fine, but the “element does not exist” error returns after working on different pages and returning to the homepage where I set the interaction.

Maybe I’m doing something wrong here? This is my share link (the interaction is set to effect “Nav Block”:

And here is the published version:

Hi there,

I’m experiencing the same “This element does not exist on this page” while using interraction 2.0 and following, step by step the page transition tutorial from Nelson.

I get this error message, when I try to apply the page load animation (that I set up earlier) to another page. It seems like the animation doesn’t recognise the overlay div anymore… but the overlay div is there too !

I just don’t understand what I’m doing wrong unfortuneately.
Has this “element does not exist on this page” message actually been resolved yet or is it me doing something wrong (again) :slight_smile:

Have a nice weekend you all ! :sunny:

Here a little video record of my workflow:

Here a screenshot:

You might need to redo the interactions with the new feature that was just released:

have you tried this yet?

1 Like

Amazing, that did the trick !

Sorry I haven’t noticed this update !
Really cool feature indeed !

Thank you :slight_smile:

1 Like