Image unexpectedly resizing


I have been working on some ideas for my site, but i’ve run into some trouble. On the mobile version of the site an image in the viewport (both in design mode & in preview mode) suddenly resizes, and sometimes will switch back ad forth between the sizes.

Actually as I was typing this I observed it in the desktop version as well after switching some things around. what is it I’m doing wrong & how can I fix it?

You may observe the issue Here

Here is my site Read-Only: LINK


Did you fix it? It doesn’t resize for me on Chrome.

Hmm, maybe. I tried switching the image from sizing based of a max width % to a px value. That may have fixed it.

Though I had one other question. When the image in question is moved towards the bottom of the section it will pass over into the next section even though I have no visible overflow set. Is this because the image is bigger than its div, or something else?

1 Like

Well now I’m even more confused. So your right, in the read only link on chrome the image isn’t resizing, but in the actual designer it is.

I sat and watched the read only link for a bit and it never resized, but like clockwork in the designer at about 1 1/2 rotations of the white sphere the image will change size. After the image remains smaller in size, until I touch any parameter that changes its size or location; then it bounces back to the full size image.

After a little further investigation I found that in both the preview and designer mode the size will change at precisely the same time. I timed it at about 9-10 seconds after returning to full size it will change size again.


Did you ever figure this out? It’s happening to me now!


Bump, this is happening to me now. I am not touching any of the control settings, image just keeps bouncing in the editor by itself.


Me too! I always have this issue in Webflow like image resizing itself or even they’re with the same class as other images. The 1st image does not bounce but some of the others resize themselves. It makes me so frustrated.

Same problem here. Probably error in % sizing.

Hello, any solution for this? It keeps on happening in the designer page, it randomly changes all the time :frowning:

I tried to put PX value and % value, it’s still doing it.

I am having the same problem.

1 Like

Also having this issue.

Also having this issue. Really really annoying

Hmmm. It’s sounds like an issue I’m having…
Someone must have responded to this old post the same time I posted mine…

I sure hope someone can help us all! OR Webflow needs to fix this issue. It really lowers the quality of my site.

Hi, Just had the same problem too so I did a lot of troubleshooting/trials and error and might off found a solution and so far it’s worked for me:

Basically, for your image that is randomly resizing, just go back to where you’ve exported that image and just simply re-export it again (either png or jpeg formats) and try to have the image file size under 1 MB (within the KB) then re-upload the image and hopefully this should solve/stop the randomly rotating image.

Please let me know if this works for you guys too.

The only fix i found is to have the image set as a background for a div block and control the div itself rather than have the image inside the div.

1 Like


Webflow needs to rescan and generate variants for the images. Read more here

Mac: Command + Shift + I
Windows: Control + Shift + I


Dave’s response seems to work for me. I hope Webflow can fix whatever is causing images larger than 1MB to randomly resize. I decided to give Webflow a try after seeing the incessant ads. This bug was almost enough to never use Webflow again

I think I just solve the same issue, for me, it worked.

  1. I checked my file’s sizes W/H and KB on my PC. Change if needed.
  2. Then I placed it in the workflow editor and checked the image’s parameters in Image settings. All parameters must be specified. (See the picture)

If everything is done correctly then it will work how it must. Hope this will helps.

Screen Shot 2022-10-15 at 13.31.36


SUPER helpful! Thank you!

This worked finally. Image parameter was reading as ‘X’ so deleting and reuploading the asset brought the dimensions back, which seems to have fixed this issue.