Iframe Media Displaying in Webflow Staging but NOT Hosting

Hey Guys,

I have an iframe that is displaying media — an HTML5 PDF flipbook from Flipsnack.com — correctly when I publish to the webflow staging environment but NOT showing up when I publish to my webflow hosting.

Same exact iframe code, same exact URL file path, same everything. I am publishing the same project in parallel to both.

staging version of page:

domain hosting of page:

iframe source code :
<iframe src="http://donnatrumplova.com/darknet/flipbook/assets/iframe.html?hash=ftu34j33z&bgcolor=EEEEEE&download=1" width="100%" height="100%" seamless="seamless" scrolling="no" frameborder="0" allowtransparency="true" allowfullscreen="true"></iframe>

Interestingly, I had absolutely no problem getting the media to show up in both the staging and domain versions of the page when I was using an embed code with files hosted by Flipsnack.

But this file path is pointing at my server now. I need to host this media myself, unfortunately.

http://donnatrumplova.com/darknet/flipbook/assets/iframe.html

Look, the iframe also seems to works fine when I test it on a page hosted by one of my servers…

http://donnatrumplova.com/darknet/flipbook/test.html

I have tried everything, including talking to Flipsnack’s tech support. But the issue seems to be existing on Webflow’s domain hosting alone.

Thanks in advance for your help!

If you publish your site with SSL, then the iframe embeds you’re adding to it must be SSL too (so a URL starting with HTTPS).

.io staging isn’t SSL, that’s probably why it works there.

An https path does not work now but I realized I don’t have any SSL certificate installed on the hosting domain.

This widget is hosted on a domain on a Dreamhost server. It’s been awhile since I messed with server settings but I know SSL is pretty easy to install…

In theory, if I do this, the file path with “https” should start working, correct?

It works…

Thanks Vincent!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.