Streaming live at 10am (PST)

I connected a custom domain, updated the DNS settings and now getting a 301 redirect loop

Hi everyone,

My domain is on NameCheap. I updated the DNS settings as recommended. I even set the www domain as the default on the webflow’s side (although NameCheap claims to support CNAME flattening). The site won’t work - I am hitting an endless 301 loop between http and https.

What could be the problem?

And I just performed a check with a DNS checking service and the DNS is propagated properly… so i have no clue where this 301 redirection is coming from…

It looks like you have HSTS config causing ->(307)
You also have ->(301)
If in Webflow you have default domain set to www this shouldn’t be doing a redirect.

@Sherzod_Gafar thank you so much for posting about your DNS configuration issue with setting up your custom domain. You will want to set your www version of your domain as the default domain to prevent that redirect issue which you’re experiencing.

This seems like a sensitive account / technical issue, and we’re here to help. It is likely we’ll need to investigate and discuss your private account details. Could you please contact our Customer Support Team at

One of our Customer Support Team Specialists will be able to investigate and respond via email! Thank you so much!