I cant edit as an admin with CMS enabled

I have just converted my site to enable CMS so I have no other users than myself as an admin user.
When i click CMS in the dashboard a new page is opened. The upper part is grey with a “Back to live site” button and in the bottom of the screen I have CMS login but if I enter my Admin user and pass it says i can only enter CMS through the dashboard.

So, i cannot enter CMS edit mode. How do I do?

My site http://cmstrafikljus.webflow.io/ (private with password sorry, but the content is not public)

You need to enter the CMS mode from within your dashboard, not (yet) possible to login as admin user on the website itself, unless you have CMS hosting connected with your website.

But how do I enter CMS mode from my dashboard? I tried the big purple CMS button in the upper right corner but that does not work. That just opens the site with the cms-login that doesnt work.

(i guess it doesnt matter but i am on the Proffessional plan right now)

that might be a bug then since when i click on that purple button in the dashboard im getting logged in automaticly.
Might need to contact @webflow thro the email and provide them a share link so they can have a look

Ok i sent @webflow a private message in the forum. Hope that was what you meant and hope to have an answer soon. I tried setting up a new webflowsite with CMS and i got the same error so it was not site specific but maybe specific to my user.

Hi @eemr, thanks for the post on this. If you are using free hosting, do the following from Site Settings:

  1. Publish the site
  2. Click the CMS button

If you would like to send an email to support@webflow.com, I am also happy to help you with this directly.


That is exactly what i do. I use free hosting but will move to paid hosting if we get everything to work.

In step 3 as you described i get the following error when i try to login with my admin user, i e my webflow account credentials.

Hi @eemr,

Thanks for the update. Could I ask you to please send me an email to support@webflow.com, from the email you have registered in Webflow, and that way I can take a look at this in more detail.

I do not want to share any personal account details on the Need help pages, so if we can continue this conversation in support@webflow.com, that will be great. Once the issue is found, the post can be updated with the resolution.


ok i just sent you the email.

Hi @eemr, thanks a lot. I have tried to replicate this, but I have not been able to duplicate this strange behavior yet.

Here are some additional things to check:

  1. Clear your cookies and browser cache and then re-login to Webflow
  2. Try opening a Private Browsing window and using Webflow
  3. If using extensions, disabling those may help (recommended)
  4. Use the Chrome Browser (recommended)
  5. If using Safari 8.x, Upgrade to Safari 9.0

Let me know how it goes. I am here to help.

Was about to say just make a fresh website and see if the error there also happens, but you are on the free plan so cant make more then 1 project. Or is it still possible to make more public websites @cyberdave? coudnt find that information on the pricing page.

Problem solved. Cleaned cash and extensions and reboot… :wink:


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.