How to set Sliders to 'auto-play' from Slide 1 only once scrolled into view?

Hi Webflow gurus!

Does anyone know how to trigger Sliders to only start auto-playing when they are scrolled into view?

I have tried an interaction, setting the initial display of the slider to ‘none’, then to ‘block’ when scrolled into view, but this didn’t stop if from auto-playing on page load.

Any help or advice would be greatly appreciated!