Streaming live at 10am (PST)

How do I remove the white frame on videos?

Self explanatory, guys and girls, any help appreciated!


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

May we see a readme file? The border could be coming from differing causes

Thanks for your answer! here it is:
https://preview.webflow.com/preview/kolapse?utm_medium=preview_link&utm_source=designer&utm_content=kolapse&preview=e671925194beef367d7369311686546e&workflow=preview

Sorry - that link is inaccurate

sorry!, the link it’s fixed now:
https://preview.webflow.com/preview/kolapse?utm_medium=preview_link&utm_source=designer&utm_content=kolapse&preview=e671925194beef367d7369311686546e&workflow=preview

I find NOTHING in Webflow that may be causing the border. The vimeo site shows it with no border but I suspect the border IS coming from there. I’m not a vimeo user, never have used it, so I have no clue about videos from there.

Thank you for your answer Jim, it happened with a YouTube video too. If I use the YouTube video element, the white frame doesn’t show up (but I can only link a YouTube video). The white frame happens when using the “generic” video component.

I had an idea. Went and got the embed code from the vimeo site and embedded it into your Webflow


No border. Change the size in the embed code should do the trick

Oh, that´s wonderful, thank you!

Hey Jim, for some reason I can’t get it to work. Maybe I’m missing something. This are the steps:

  1. create a div block for the video
  2. drag the embed component inside
  3. Go to the video an Vimeo and copy the code
  4. Paste the code on the console

When I publish it deosn’t show up…

If I copy the code being the video 640, it works, but if I select “responsive” and copy that code, it doesn’t seem to work.

Screen Shot 2021-12-28 at 3.07.08 PM
Click on that


Copy embed code from vimeo there
Screen Shot 2021-12-28 at 3.08.34 PM
Be sure to save & Close
Screen Shot 2021-12-28 at 3.08.11 PM
open code editor to make changes

Thank you Jim! I just realized it was a very silly thing on the div block settings.

I’m sure you are familiar with the background video element. I added a quaint addition. I was asked about embedding a Powerpoint presentation into Webflow. I saved the PP presentation as a video (.mp4) then use it as a background video. The ‘video’ element doesn’t accept native video but the background element does.

No player controls - just a 4 second delay and transition.

https://preview.webflow.com/preview/amazing-site-36e308?utm_medium=preview_link&utm_source=designer&utm_content=amazing-site-36e308&preview=b985b1840180028b20158368b97574de&pageId=61ca644364f40a0063ead1ab&workflow=preview

hi pablo, could you tell me what you did to fix it? i am facing the same problem.

Hi Dane, from my experience, if you use the normal video component and simply paste the video link (not the YouTube video component), it shows the ugly white frame around it. But if you use the embed component, the ugly frame doesn’t show up. You have to go to Vimeo or Youtube and get the embed code and paste it in the embed component. Watch out: you likely would put the embed component inside a div block, check out the div block height, it could be so small that it could look like the video is not there, but it’s actually there. That’s what confused me until I figured it out.

1 Like

Thank you very much Pablo! I will try this way.

You are welcome! These are the sizes I gave to the div block that contains the embed component:
Screen Shot 2022-01-05 at 19.30.37

Thank you for all the tipps. But the thing is that the only platform I host videos on is YouTube. And they don’t offer an embed function. Also you need to have a site-plan to embed something. I tried many things to get the border removed but I didn’t find any way. This is so nerve wrecking…

Never mind. I realized that there is a YouTube Element. I replaced it and the frame is gone. Sorry for the unnecessary reply.