Streaming live at 10am (PST)

Having trouble with mailchimp integration

Hey guys, how are you doing?

I am having a issue with the mailchimp integration. When the email is submited the button keep saying “please wait” and don’t confirm the subscription. What should I do?

Here is the troubleshoot link:

Thanks you!

Where is the form on your site? Also can you publish the site and post your subdomain here too?

Hi Sergie,

The form is in a modal/pop-up made from the forum tutorial. Sure. Here is the subdomain:

Thank you

You somehow dragged the Form element out of the Form Wrapper element. The Form Wrapper is important to make the form work. Can you drag in a new form above that form in the modal and then drag the form elements from your original form to the new one?

That should fix her up. :slight_smile:

Hi Sergie,

I am still having the issue. The Form Wrapper was still there when I’ve changed to the other form. I will have another try now.

Try to remove the custom action that you added for mailchimp, then see if you are able to submit the form normally to Webflow. If it works it must be something wrong with your mailchimp integration.

Thanks for tips Sergie, It was a problem with mailchimp indeed. I have opted to make it a direct link to a form besides having the form there as I need the users to make to the list.

Thank you bro

Hi @thesergie, I am facing the same “please waiting” issue when trying to use the Mailchimp Integration.

Is there a fix for that?


This may shine some light on the issue:

Does it always happen or only sometimes?

I would also suggest that when testing your mailchimp form- be sure to use different email addresses. If you sign up with the same email address over and over again, mailchimp might reject your submissions to avoid spam.

Hi @thesergie and @danro, thanks for your comments.

During the time I tried this yesterday it was a permanent behaviour. I did try with different emails. I am not quite sure but I believe that te integration was ok, the issue was only on the “please wait” message.

I have integrated using another method that I have used before, So I can’t easily test it anymore.

Just wonder if there is someone using this integration without any issue.


Seems to be working here. I just needed to change the names of the form fields in the “Input Settings” to match the field names in my mailchimp list. So name is FNAME (I only collect first names) and email is EMAIL. Just tested it and it worked without an issue! Hopefully this will help you guys, too!

I matched the field name and it’s still not working for me. It keep directing me to the form…

I would like to know if there is a way to submit the form over https