Grid overlapping on auto or isn't responsive at 0 margin

Hey guys!

I’m kinda new in Webflow so I’d appreciate your help, thanks in advance! :slight_smile:

I’m starting with this page where I have a container (max. width 960 px) in which I have a heading and grid with companies client is working with. I need the grid to be full width 1200 px. It works when I set left and right grid margins 0, but it isn’t responsive as when I set it to auto (then the grid is overlapping the whole page). Any advice please, what is the best solution?

Thanks and I wish you luck with your websites.


I think you just need to change the width to 100% and put 1200px in the “max width” parameter.

Thanks! Actually I didn’t get what you meant to change its width but I went with setting the container width to 1200 px and div with heading to 960 :smiley:

For future reference, see screenshot below.
Also, be sure to include your read-only link when requesting help.