Google reCaptcha not working

Hi all

We are having issues with Google reCaptcha. We have added the form element, added both the Site and Secret keys, enabled validation but we are getting an error on the form on Contact

We have tried many times with new keys and even tried two different Google accounts.

I have seen this topic posted on the forum before but not seen an answer to this issue.

Has anyone had the same issue and how did you solve it?

Here is my site Read-Only: Webflow - Equine Health Specialists

Many thanks in advance.

Webflow only supports reCAPTCHA v2 so if you are trying to use a v3 key it won’t work. That is my first guess at the issue.

Ah thats solved the issue, thanks so much. So in the backend of WF there is a link to Googles reCAPTCHA which defaults to v3.

Thanks again Jeff!

@Libramonte - I can’t debug Webflow infrastructure for you. I certainly can’t even look for a misconfiguration when there is nothing shared. I recommend that you open a trouble ticket with the Webflow support team.