Google Maps does not work :-(

Hi together,

google maps does not work (any more)! It worked befor, but not now anymore. I dont get it… :frowning:
Does anybody has an idea?



Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hi @Fred

Can you expand on ‘not working’ - do you mean it’s just not finding the address as per your screenshot, or that you can’t see it on the canvas?

Both. It seems that the address could not be found. Therefore it is not shown on the canvas. But as I wrote, it worked before, but not now anymore. I also inserted the api key, so it cannot be the probelm…

I have seen, that it is a browser issue. In some browsers the map is shown, in some not. This is really annoying… Is it a bug?

We’ll leave it in the Bugs category for now, and i’m sure one of the bug/support team will take a look later.

Hi @Fred

Thanks so much for posting about this and great questions.


This is not a bug, but expected behavior based on an update we’ve made. In May of last year we changed the way Google Maps integrated with Webflow. You can read more on this update here, but basically last year, Google removed keyless access to their API, requiring everyone to supply an API key to serve their maps on their site.

Creating a unique API key for Google Maps has been the existing workflow since May 2017, but a few sites’ maps were still using the original API Key for integrating Google maps which was fully deprecated recently. This is why your Maps stoped working today, rather than last year.


You can get the Maps on your project working again by generating a new API Key. You can follow this guide for the exact steps:

If you run into any issues here, definitely don’t hesitate to reach out.

Hope this helps!

1 Like

Our team pushed a fix for this issue :tada:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.