Problems with Google maps

Hi everyone,

I’m having an issue adding new addresses to my Google map. It was working fine for months but all of sudden, whenever I try and add a new address, I get an error message that says “we couldn’t find that address”

I generated/activated a new API to see if that would help but I still get the same message.

Anyone have any ideas on what might be going on?


Here is my site:

Exactly the same with me too… I have signed up to API - entered card details and done everything which is required however when I enter an address - the address could not be found! Help!

Hi @ptrnelson @Stevekeystage

Thanks for posting about this Maps issue.

Our team ran into this earlier today and we are currently investigating to find the root cause and a fix.

I’ll be sure to keep you all updated as we learn more.

​Thanks in advance for your patience :bowing_man:

Hi All,

I have setup and created an API - entered the API into Wordflow - Google Maps - Maps now works fine but when I add/configure an address it states that ‘We Couldn’t find address’ !
I have tried a variety of address locations to test but nothing could be found…

Any help please?

1 Like

Hi @Brando

I’ve just merged Steve’s previous post here.

Also, is it connected with this thread yesterday? The original screenshot also had the red address ‘could not find’ error…

Awesome, thanks a ton @StuM

That other thread definitely may be related to this issue. To test this, @Fred, can you please try generating a new Maps API Key by following these steps:

If the issue persists after using a new key than that thread is related to the issue here :slight_smile:

​Thanks in advance, and I’m standing by for your reply!

1 Like

I’m having this exact same issue.

I’m trying to add a map to my site (linked below), but the address field in the maps component doesn’t seem to recognize addresses that I type in. It’s default is to point to London, but I need to change it to a specific business address. I’ve updated my Google Maps API code in my dashboard as well. Is this achievable without custom code? Or is the map component feature broken?

Thanks in advance for any help.


I just created the key a few weeks ago. So there should be no problem, no?

Hi @Fred @Danny_Weilandt @Stevekeystage @ptrnelson @StuM

Thanks again for bringing this up. Our team was able to push a fix last night — you should be able to use maps as expected now. :tada:

Thanks for your help and patience on this.

All working for me now, Thanks for the support and dealing with the issue. :slight_smile:

1 Like

All fixed on my end as well. Thanks Webflow !!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.