Streaming live at 10am (PST)

Google "couldn't fetch" sitemap

I’ve been trying to get Google to index my website (now live for over five weeks) to no avail. The Search Console notes “couldn’t fetch” when I plug in the sitemap. I most recently tried to re-submit two days ago (see below):

For reference, I have checked YES for Disable Webflow Subdomain Indexing and YES for Auto-generate Sitemap under the Webflow SEO settings. The site is verified with Google.

Any suggestions?

Share your published link please. You should check to make sure your not excluding bots with a robot.txt directive.

The published link is https://www.hershandhurd.com.

One additional flag – when I go to the old Google search console, it’s listed as pending as it has been for weeks.

If you manually added this https://www.hershandhurd.com/sitemap.xml first line in the robots.txt file from the site settings, you should remove it. Webflow automatically appends the correct syntax and path to that file. That first line is not formatted in the correct syntax.

While the robot should ignore it, no guarantees that it won’t cause an issue.
The file is visible and Google has indexed all the pages listed in the sitemap.

This is a bug on Google’s side, not yours. We had the same issue with several clients’ websites, Google keeps promising to solve it but no luck so far. Try submitting each page manually:

  1. Go to URL INSPECTION
  2. Type in the URL
  3. Click REQUEST INDEXING

Extra manual work of course, but a temporary solution until Google sorts it out.

VOLT LAB

1 Like

I had the same issue: Google Console Couldn’t fetch my sitemap. I even made a custom sitemap to try my luck. After a few days of trial and error, I came across another issue: My non ‘www’ version was not redirecting to my ‘www’ root. So, I had to manually follow instructions to set up the DNS records. After I did that (and I chose my ‘www’ as the default domain in Webflow), the sitemap started to work. Google Console was looking for my sitemap at https://mydomain.com/sitemap.xlm which was not working. I hope this helps.

I had this problem, so I wanted to bump this post for anyone else who might be struggling.

This worked right away for me: Use the slash at the start like this → /sitemap.xml

Here is the article I found the solution on: