Facebook pixel not activating

So i have created an facebook pixel and installed the pixel ID in the project settings. When i try to send test traffic to the site, i am informed that the pixel has not been activated.

I have the facebook pixel helper, and it gives the error “We detected event code but the pixel has not activated for this event, so no information was sent to Facebook. This could be due to an error in the code, but could also occur if the pixel fires on a dynamic event such as a button click.”
But as i understand, this should not prevent the pixel from loading?
Any help or suggestion would be greatly appreciated.

I’m having the exact same problem, were you able to figure it out??

I have the same issue and following this thread!

same issue for me! Anyone figure out a solution?

After pasting the ID in the dashboard, are there further settings to change on Facebook itself?

Also having the same issue, super frustrating…

Any update? :frowning:

I also have this problem, anyone was able to fix that?

1 Like

I was able to fix this problem. I had the pixel ID added in the Integrations tab of the Settings page. I had the same error: “We detected event code but the pixel has not activated for this event, …”. However, my problem is that I had “Delay for cookie consent” switched ON.

If you are having issues:

  1. switching it to OFF
  2. Hit SAVE
  3. Hit PUBLISH

Missing any one of these steps will mess up your setup.

Since no one has replied with this intel, I figured I would revive this thread…

Disable AdBlock, Ublock, etc! This solved it for me.