Facebook pixel found, but not activated

Hi, so i have created an facebook pixel and installed the pixel ID in the project settings. When i try to send test traffic to the site, i am informed that the pixel has not been activated.

I have the facebook pixel helper, and it gives the error “Pixel Helper found your Meta Pixel, but the pixel has not been activated for this event and no information has been sent to Meta. This may be due to an error in the code or if the pixel fires on a dynamic event, such as a button click.”

I have tried to research this on other webflow forums and some people have made it work by switching the “Delay for cookie consent” OFF. But I have already tried that and it dosnt work.
I have also tried to disable AdBlock but still dosnt work.

Any help or suggestion would be greatly appreciated. Thank you very much!

We have pixel working for the root URL, but any other URLs do not fire the PageView event.

Difficult to determine - is the problem in Webflow? Cookie consent seems like the most likely culprit. Or is something off in the configuration on the Meta Events Manager?

Not really sure what to try.

Having the same issue. My guess is that it is a problem with Webflow

Webflow generates HTML and CSS, and serves your site.
It doesn’t sit between the browser and META. It would be very difficult for it to affect your pixel code.

You can use devtools and META’s debuggers to inspect the code, your pixel’s interactions with META, and figure out where your problem is.