Streaming live at 10am (PST)

Facebook Pixel - Event tracking issue


I have added my Facebook Pixel ID to my Webflow project settings and I am getting an ‘Active’ status back in my Ads Manager panel, so the Pixel is there and working, however, when I try to set up events I get this error message (attached) saying there is no Pixel on this website.

Anyone know why? There isn’t an additional tab active etc. as it suggests.


Hi @Reece_Gunningham

I answered the ticket you’ve sent in but I’ll answer you here as well.

When I try the URL through a Chrome extension that checks for Facebook Pixel I get a positive response that there’s indeed a pixel on that URL.

Let me know if you still having trouble here and I’ll try to investigate some more.

Kind regards,

Jörn :sweden:

Hey @jorn

I’ve created a loom video of my issue as I follow along with a youtube tutorial.

Is the new Event Tracking Tool not compatible with Webflow?


Hi All,

I was having the same problem and I fixed by doing a manual installation of the Pixel. Instead of using the integration in webflow by just adding the pixel ID, copy the custom code from FB pixel installation and added to your Header under Custom Code in webflow setting panels.

did you remove the FB ID when you put the code in?

Yes, I can confirm that the code that WF generates for FB Pixel is incorrect. (Perhaps outdated.)

If you enter your FB Pixel ID into the Integrations area of the site settings page, it inserts this in exported sites:

<script type="text/javascript">!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';n.agent='plwebflow';n.queue=[];t=b.createElement(e);t.async=!0;t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,document,'script','');fbq('consent', 'revoke');fbq('init', 'YOURPIXELIDNUMBER');fbq('track', 'PageView');</script>

It should be:

s.parentNode.insertBefore(t,s)}(window, document,'script',
fbq('track', 'PageView');
<noscript><img height="1" width="1" style="display:none"

I’ve missed out on 2 years of analytics. :frowning: I wish I had known what to look for and how to set it all up, but I’m glad it’s working now.

Yes, you should do this so WF doesn’t generate that incorrect code. It probably won’t break the correct code, but why have redundant code. Removing your FB Pixel ID from WF’s Integrations settings tab will stop WF from generating that (broken) code.

Hi @daxliniere I have used your code in my header but my Facebook pixel is still not picking up any activity. I have filled in my pixel ID number in the code and refreshed the page etc but still no luck. Do you have any experience with that issue? Thank you