Every attempt to import has failed

I’ve exported all of my articles from my collection “Products”.

I’m trying to make bulk changes in the sheet such as adding Categories, and Names to each product. I do this by opening the CSV in Google Sheets, making the changes, and then downloading as a CSV to import back in to Webflow.

I’ve tried several times importing, and every import gives me “All items failed to upload”.

Each time, I’ve mapped all fields, except a few which I don’t see a way to map: Collection ID, Locale ID, Created On, Published On, Updated On.

Everything else looks like its mapped correctly.

What could causing my import to totally fail?

**I should note I originally imported my content when the site was blank, so I know importing in general is working and I used a Google Sheet to create my CSV file. I just haven’t been able to bulk update content via CSV import.

Here is my site Read-Only: LINK
([how to share your site Read-Only link][2])

I’ve stumbled upon the same frustrating issue with bulk CSV imports and wanted to share my experience, which might shed some light on this perplexing problem.

Like you, I exported my articles for bulk editing in Google Sheets. Post-edit, my imports were consistently failing with the “All items failed to upload” message, leading me to suspect a systematic error rather than a one-off mishap.

To isolate the issue, I conducted an experiment where I systematically deleted columns and attempted re-imports to identify any problematic fields. This step, unfortunately, did not resolve the issue.

When I attempted to import the CSV as an update to existing items, I encountered the error every single time. Yet, interestingly, when I opted to import the CSV as new items, the process completed without an error. This was curious because it suggested that the contents of my CSV were likely formatted correctly, since the import as new items worked flawlessly.

This has led me to question whether there’s a bug with the ‘override existing items’ feature. A few weeks back, everything was working as intended…

Nate, could you clarify if you were attempting to import as new items or were trying to override existing ones? Also, has anyone else encountered this issue?

1 Like

I’m experiencing the exact same problem. There’s no way to update existing collection items in bulk.

1 Like

I was attempting to update items.

When I did an upload as new items, it creates new pages for all the content, so it never does update my content.

Hey Colin!

Why the heck is the option to even update items then? This was a defining reason as to why use Webflow over other products for me. I’ll be pretty bummed if there really isn’t a way to do this. :confused:

Webflow has always had limits on what functionality they provide. Since they promote the new App Marketplace there are apps that would allow the sync of collection items from other sources.

Look at

I have not used either so I can’t comment on them personally.

You could also potentially leverage Zapier, Make, Parabola, etc. Worth investigating.

If you want to take things to another level you could just leverage a remote data source and use custom code or a product like Wized. There are SEO considerations that you must take into account.

1 Like

Thanks. Super appreciate the links.

The point of me working off a sheet is so I can be meticulous with SEO in mind.

One thing I keep running up against is the important can’t seem to map to category names consistently. It’ll find some that are referencing another collection, but within that same collection, it can’t recognize other category names and the entire import fails.

And incase any Webflow people read this—the download summary is useless. At least print out the errors. That would be wonderful.

Here’s an example:

First, here’s the collection of Company Names showing 1500 Cubits is part of the collection:

Then, when I try to bulk upload to a different collection, it won’t recognize 1500 Cubits when I attempt to map those fields.

But this issue isn’t consistent.

On that same upload, here’s the upload recognizing the Company field, but not the Category field.

And then, we have one where the Company field can’t be mapped, but the Category field does map.

Rather frustrating.

I would run the files through a CSV validator to make sure there was no issues. If pass then reach out to support.