ERROR: No collections inside symbols on utility pages

Ran into this perplexing edge case so I thought I would share.

I have a Footer symbol that is used site-wide. Inside of that footer symbol is a collection linking to new collection items. Placing collection inside of symbols is something I do regularly for menus, nav, footers, and so on.

Today I was trying to add or replace the collection in the footer when I kept running into this error.

Sorry, you can’t add a Collection List to a Symbol that’s used on a utility page.

There are three utility pages, Password, 404, and Search Results. I immediately went to the Search Results page since that’s where I’d been working most recently. That’s when I realized the Footer symbol was there. Of course I want the footer to be on the search results page, but in order to figure this error out I removed it from the page.

Then I went back to the other page where I was working. Opened the footer symbol and was able to place the collection list into the footer with no error. Out of curiosity I went back to the search results page and tried to add the footer symbol back in. It worked. No errors.

So my two-part question to @webflow is this, what is the purpose of this error if it is easily bypassed and is the work around creating issues with the published site?

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hi @matthewpmunger, thanks for the report, that sounds like strange behavior, although I don’t think it should be affecting to the published site.

As soon as I have more info to report, I will get back with that update.

Thanks in advance

Hi @cyberdave any news to this, just bumped into the same problem.

@matthewpmunger did you find any solution to this?


Yes. The work around is to remove the symbol from all utility pages. Then on a different page make your changes to the symbol such as adding a collection list. After changes are complete, go back to the utility pages and place the symbol back into the page.

The work around is not difficult as long you understand the meaning of the error when you see it.


Hi, I’m having a similar problem. I have a utility page (404) with no navbar at all. I tried to add a navbar symbol which includes a collection populating a dropdown list. However, I can’t add the symbol at all to the utility page because I keep getting the error message. I really don’t want to have to create a solution where I need to create a separate navbar for this page using hard coded links in place of the collection list. Any ideas? Thanks.

Hi @starfish @jorn @matthewpmunger

Thanks again for pinging this. It looks like dynamic items are not allowed on the Password or 404 pages at this time.

I reached out to the team to see why this is the case, and to see if it would be possible to change this in the future. If we are able to add dynamic items to these Utility Pages, I’ll be sure to create an Internal enhancement request and keep you all updated.

Thanks for your patience!

1 Like

Thanks Brando. Guess hardcoding the links is the only way then! I’ll look forward to the update.

Hi @starfish @jorn @matthewpmunger

After chatting with the team it looks like dynamic lists aren’t allowed in utility pages by design. You can add symbols to utility pages, but just not dynamic lists.

It’s unlikely this will change in the future as allowing collection lists on the 404 and password page will cause other issues including performance on all CMS powered sites.

I hope this helps clarify!

1 Like

Thanks for the update @Brando.

So it sounds like, even though I found a work around, I should remove the collection list from the symbol on the utility pages. Good to know.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.