Streaming live at 10am (PST)

Elements in CMS Item not showing CMS settings options

Here’s the situation.

I have a site footer that is a symbol. Inside of the symbol is a collection list. In the list’s items are simple a link block with an image and text inside.

The collection is pulling in the correct information that it had been linked to. I need to change the image to pull the 16:9 image from the CMS collection instead of the 1:1 square image it is using currently. However the option to remove or change the link to the CMS fields are gone.

If I add a new image into the CMS collection item, the issue persists.
Also tried using the designer in Safari and Chrome, the issue persists.

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Found a work around, but I want to keep this post open because the bug is still there.

What I ended up doing was to duplicate the symbol. Unlink one of them. Then the CMS setting options became available as they should be. Made my adjustments and then copy/pasted the adjusted collection list back into the symbol and erased the old one. When I tried only copy/pasting the image element, it didn’t work. That’s why I replaced the whole list.

Again this is a work around and not a solution to the bug.

Hi @matthewpmunger

Thanks so much for posting about this.

Our team is investigating this right now and looking for a solution.

The best workaround for the time being is to unlink any collection list from a symbol. This will allow you to edit the bindings without any issues as you mentioned.

I’ll post an update here as soon as I have one.

1 Like

Just wanted to let you know, I logged in to the bug section here to report this same bug I discovered the other day. I’m having this issue with my nav pulling latest articles in from a collection. I have my nav as a symbol on every page, and the site is growing every day with the need to constantly add the new content to the nav.

Thanks for letting me know @ThreeProngs. We are still working towards a solution for this one. In the mean time, the best workaround would be to unlink one symbol instance of the navbar, make the necessary changes to the collection lists, then copy/paste the updated nav to all other pages.

We hope to have this resolved soon and I’ll post an update when we do.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.