ERR_SSL_PROTOCOL_ERROR - Namecheap & Webflow

Hi –

I’ve been trying to connect my Webflow project to my Namecheap domain (

These are my settings in Webflow:

These are my settings with Namecheap:

I was in a chat with the Namecheap support last night and they said everything looks fine on their end, and the site is propagated.

This the error I get for both, &

Can anyone help with this? :slight_smile:

Try republishing your site. If that does not work then contact support. Your DNS records appear correct (I just checked Google DNS).

Thanks for looking into this! Did you mean republish as in from the Designer - or re-connect everything to Namecheap?

I’ve reached out to Support but the Forum is 100x faster. Yesterday they got back to me within an hour but I haven’t heard anything since then.

Anyway, thanks again for checking!

The DNS looks correct as I said. I would define the www subdomain in Webflow as the default then publish the site. Should resolve your issue.

I did. It’s still not working, unfortunately. I’ll just have to keep bugging support.
Thanks Jeff!

In your screenshot www is not the default. The root domain is. This is often an issue.

Yeah, originally it was set to www, then I changed to root in an effort to just try different settings. I changed back to www after you mentioned it but it’s still not working.

Make sure you republished and the default domain was selected (checkbox), not just the domain.

When publishing from the Designer? Yes, I did that. Published to both domains (default & io).

Well I have no additional suggestions for you and can’t inspect anything else as I am just a forum member. Good luck with support.

Really appreciate your effort, Jeff! Thank you!

1 Like

I solved it. Which is a surprise because I’m quite obviously an idiot. :flushed:

The solution lies in the subtle difference between .co and .com! Duh.

Thanks again for your help!