Streaming live at 10am (PST)

ERR_SSL_PROTOCOL_ERROR ! Can't launch new site!

So I suspect there is a problem here…

I have tried publishing my site twice (adding a custom domain) and am getting the same error:
ERR_SSL_PROTOCOL_ERROR
https://www.ashevillehomecrafts.com

The domain provider is GoDaddy. The first time, I used the automated option for the records to be changed. No errors were shown on the settings page. I waited an hour overall. The A records (checking at https://www.whatsmydns.net/) were propagated almost immediately, but the issue is with SSL.

I got tired of waiting and changed the DNS back to our old hosting. Changes were propagated back fully with 5 minutes.

I then decided to try it one more time… I removed the custom domain from the project settings. Then, I decided to go the manual route and add the A and CNAME records myself. I republished the site after the settings showed green checks and the same error is back. I’ve allowed 30 minutes to pass again before posting this. I know we’re always told that it could take up to 24 hours for full propagation, but I have never ever had a site take this long - with any host or receive this particular error.

What’s odd is about half an hour prior to launching this site, I launched a different one. And it was successful, propagating in minutes. Its SSL is still working fine.

Does this have anything to do with some of the things that were coming up on the Status page? https://status.webflow.com/
I can’t detect any issue at all on my end.


Here is my site Read-Only: [LINK][1]

Hi Jamie,

I’m having a similar issue at the moment. I see your site is now up and running, can I ask what the solution was for you?

Thanks

Hi there… the solution was simply to wait.
I sent a support request for them to look at it and the problem they said was from an “SSL certificate provisioning delay”. It took about 12 hours to resolve from what I can remember. But there was nothing I had to do on my side.

Ok I’ll wait to hear back from them then. Thanks for getting back to me!