Streaming live at 10am (PST)

Ecommerce Shipping Bugs

It seems that both weight enabled and quantity enabled shipping are not working in the UK mainland zone. Any way I try to do this, it simply removes the product from the cart at checkout page and has wasted a lot of time today :frowning:

In addition, if you add a product to your cart on published preview and DON’T remove that product but later remove it from ecommerce, it will put you into a loop where it cannot remove that product from the cart. The only way around this seemed to be republishing to a different domain name which clears the cart.

If anyone is experiencing similar issues with UK shipping zones, I’d be interested to collaborate as it seems to me this is just a major bug right now?

Here is my site Read-Only:

I’m currently experiencing this exact issue… I even tried reverting back to an older version of the site that was able to take orders but didn’t have any success. Almost seems like a larger issue possibly?

Really hoping to find a fix for this today…

Hi, @originalbear and @nathandennisdesign!

Thanks so much for posting about the issues you’re having with your Ecommerce stores. I’m so sorry for the frustration this must be causing.

I’m passing this along to our team right now to investigate further. I’ll respond here as soon as we know more.

1 Like

Awesome! Thanks @rileyrichter . Looking forward to finding out what the problem is.

Here is my read only link as well:

thanks @rileyrichter. Just for further info, I replicated the issue on another webflow ecommerce site currently running with flat rate shipping. As soon as I went to quantity based shipping, the problem appeared so definately not a site specific issue.

Hi, there.

​I just wanted to provide an update that our Engineers were able to locate the root cause of the issue and pushed a fix.

​Would you be able to republish your project, and check to see if the problem is now resolved for you?

​Thanks in advance :bowing_man:

1 Like

Hi Micah, I’m getting a different result now. Again using a basic shipping rule, 2 prices for quantity based. It initially appears in the cart, the moment I enter an address, it removes the product from the cart at checkout stage.

1 Like

We are having the same issue over here.
Products in checkout seem to be okay until any shipping information is entered. Then the checkout totals disappear.

Also, in the Designer, the product totals in the Checkout page appear as NaN.

Verified the issue on Chrome, Edge, and Safari on site and client-side. No issues in Console.

Hi @bowserbrit @originalbear

Have you tried to republish your project and clear your cache to ensure you have the latest build? The fix we pushed appears to have resolved the issue in some cases.

I’ll report this info back to our engineers and get back to you all asap with more info.

​Thanks in advance.

@Brando tried this on a clean browser to eliminate cache potential but no change. Its improved that the product stays in basket but the moment you enter an address, either manually or using auto-fill, product vanishes from basket. Lead time for fix would be really helpful right now as my client is getting a bit stressed about the delay!


1 Like

Same thing here. Cleared cache and still getting the same issue as @originalbear.


1 Like

Thanks for the update @bowserbrit @originalbear

Our team is digging into the issue as we speak and hoping to have a fix out shortly. Thanks very much for your patience.

@bowserbrit @originalbear

The fix should be live now — can you please test once more to see if this is resolved on your end? This time the fix shouldn’t require a republish.

1 Like

Working properly on my end, on the live-site and in the Designer. Thank you! Glad to see annual client billing got pushed out too!


Looking good here to, I’ll need to put my initial weight & quantity rules back in place to properly test but so far seems to be sorted.

Thanks to the team for pushing through to get a fix on this, great job!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.