Streaming live at 10am (PST)

Dynamic List Item linked to content using Link Block


I have a Dynamic List on a collection page that pulls in featured blog posts, however when I go to click on the link nothing happens.

Any thoughts?


Hi @lindsay.ware, thank you for the question. Could you share the page name where the dynamic list that links to the collection page template?

A screenshot of the element you are linking from would help a lot :slightly_smiling:

Hi @cyberdave, yes! That probably would be helpful :wink:

Collection: The nature of wedding floral design // its all the way at the bottom of the page “Read for Excerpts from the Course”


Hi @lindsay.ware, thanks so much for the additional info. It looks like that content is not yet inserted inside of a link block. I would do that first

Drag a new link block out to the page, then put the div block containing the content inside the link block.

Finally set the link setting on the link block as desired.

I hope this helps!

1 Like

I’m having the same problem though I tried to follow the instructions above a few times.

Any ideas?

Share link:

Two failed attempts to link the card preview to the blog posts:


Hello @trystudio

Did you try to follow these steps?

Try publish site after that and check if these settings will be saved.


Yes, I think so! That’s what I tried below in the second set. Let me try again…
Thank you!

1 Like

It worked this time! I swear that’s what I tried below and it didn’t work.

Thank you!

1 Like

I thought I’d follow up because I ran into the problem again. It might be a bug. The way I was able to work around it is simply to return to the dashboard and then head back into the designer.

It wasn’t a problem doing this but I thought it might be helpful to anyone else stuck at the same place which is:

  1. you’ve made the link block within a dynamic list point to Current Blog Post (or whatever the self of the dynamic list is)
  2. then, at preview or publish the page doesn’t link to anywhere, instead it just reloads the page (adding a ending # in the link address which just reloads the page)

If you experience this, try going back to your dashboard, or logging out entirely and logging back in and trying again. It seemed to do the trick.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.