Streaming live at 10am (PST)

Dot style link on side navigation href problem after export code

Title self explanatory?

Basically when I export the links don’t bring me to the next section.

I also tried to put the whole URL + #id_section, but the result is wrong too.

I need your light!

I attach a couple of screenshots + link + Read-Only link


Here is my site Read-Only:

Hi @PabloMontero

This is a known limitation when exporting and using anchor links.

The best way around this is to update the link in your nav to be the exact URL you’ll use with your custom domain.


I hope this helps!

Thank you Brando for your recording!

As I mentioned at the beginning I tried this work around, and YES… the anchor links are working BUT… the current state of the links disappear.

Check it out:

I cannot miss this functionality.

What do you think?

Dear @Brando, I really need some light.

How could I get the dots “active” again?

As I mentioned in previous post, when I use the href for the anchors and export, the links miss the active status.

I have to deliver the website this week and this feature is key for my client’s website.

@Brando This method is not a solution. You can see how the page reloads the first time you clic over one of the dots. Plus, the active status doesn’t work.

I feel completely stuck, and I had to launch my client’s site without this functionality.

I have 3 sections with 3 IDs: sec1, sec2, last-sec.

Then a navegation menu on the side, dot style. I’ve tried all possible combination (without success) in order to make the href AND the current state of the link work together, in the link settings:

I know the first option should be the correct for exported sites, but this is definitely not working.

You can notice that:

  • There is no current state (should be bright green dot instead blue).
  • The first time you click in the link, the page loads again. After that, the links go correctly to the sections without reloading the page.

33 05

This is odd and I’m completely clueless.

I cannot believe I’m the only one having this issue, there is no thread in the forum that solves this bug.

I opened a thread two weeks ago, but it remained forgotten.

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hi @PabloMontero

Thanks for posting — this is definitely odd.

Can you please try nesting the navbar into a plain div?

There’s no need to add any class name or styles to the div. ​Please let me know if this helps resolve the issue :bowing_man:

Hi @PabloMontero

Apologies for the delay in respond to your post here.

Can you please try taking the above steps and let me know if this helps?

​Thanks in advance!


Thank you @Brando. Unfortunately, it doesn’t work, same behaviour.

Do you have any example showing your workaround working well. I guess the answer is no since I’m using my client’s external hosting.

Or maybe, have you seen another designer using this navigation successfully?

God, give me patient… but give it to me NOW!

Thanks for letting me know @PabloMontero

At this point I think we need to figure out a way to allow exported sites to maintain current states for anchor links.

I tried using the original method you mentioned for these nav links — using the section link setting like this worked:

It looks like the current state is still working after export :thinking: Are you seeing the same behavior?

Yep, the current state works as expected, but then you miss the href.

Check please:

Thank you to your first aids :smiley:

Hi @PabloMontero

Thanks for all the help with narrowing this one down.

I’ve reported this all to the team and we’ll delve into it a bit more to find a solution here.

For now the best workaround would be to use the external link approach, although you won’t be able to use the current state. Once the team has had a chance to investigate a fix, I’ll post back here with an update.

Thanks for your patience.

All right, that sounds good.

I prefer to disable this navigation, as the external link approach is not good for the UX since when you clic the page reloads and jump to the section.

Hope to see you back soon, thank you!

1 Like

Hi @Brando!

Is there any progress in this issue?

My client’s website is still incomplete due to this bug.

Please, give me some feedback. Thank you!

Hi @PabloMontero

I don’t have any new information at this time.

With this sort of issue we’ll likely need to revisit how we handle anchor links altogether which is a larger project. For now you may need to consider this as a limitation and find an alternative workaround that satisfies the client and project needs in order to move forward with the site.

We’ll definitely keep working on this one though and I’ll be sure to post updates here as soon as I have them.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.