Designer won't load Safari Version 10.1.2 (10603.3.8)

Hi Guys,

So the Designer freezes while opening in Safari for me. I have tried on multiple computers in normal (emptied cache) and private browsing over the last couple of days and get the same result.

Safari Version 10.1.2 (10603.3.8)

I am not super savvy with the dev tools but have attached all the errors I could see below


Also everything works perfectly in Chrome.

Thanks in advance!

Published Site link -

Here is my site Read-Only:


([how to share your site Read-Only link][2])


Hello, @David_Love!

Ben here with the Webflow Customer Support Team!

Thanks so much for reporting this issue you’re seeing with the Designer and Safari. This may be happening due to Safari not being up to date. I notice you’re using 10.1.2, but the current version is 12.1.2.

Is there any way you can update Safari and then try loading the Designer again? Thanks so much! :webflow_heart:

1 Like

Ahhh! I see. I updated Safari but it turns out I need to update the OS to get the latest version. I’ll update you when I have done that!

Thanks for the Reply!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.