Designer crashes when clicking elements

I’m having this exact same issue, was a solution found?

I’m using Safari 10.1.2 on OSX Yosemite (I don’t want to upgrade to MacOS because some of programs I use aren’t supported)

I’ll send over the screenshots in a second.


edit: I can’t actually find a way to send you a message, neither through my messages page or through your profile.

1 Like


If you can post those screenshots here on this thread, that will work as well!

​Thanks in advance! :bowing_man:

I’ve tried using the link above but I can’t open the console. I’ve pressed cmd+opt+J on the standard designer page and nothing happens, am I doing something wrong or could this be part of the problem?

Ah yes it can be tricky to open the console in the Designer. You can use the context menu when clicking the UI panel itself like this:

I’m sorry but this still doesn’t work. When I do the very first right click that you do in that video all I get is this:

With no inspect or anything to click on. In fact if I right click in the panel at all, it goes straight to the blank white page.

@Ben_Hughes in this case you may need to enable the developer options.

You can enable Show Developer Menu in Safari’s Preferences > Advanced tab. It will enable the option Inspect Element when you right click the page.

Sorry for the delay, it’s been a hectic week. Thanks for the help, I think I’ve got the right thing now. Is this all you need?

Thanks for sending that over @Ben_Hughes.

Can you please let me know what site this is for and also let me know what section / element you are clicking on that causes these errors? Are you able to see the error in Chrome as well? Or only Safari?

​Thanks in advance, and I’m standing by for your reply.

Thanks for getting back to me.

This is for a site I haven’t launched yet, it’s the only one in my account plus a copy of it I made to see if it would work. I’m basically following this video with some slight changes if that helps

It happens whenever I click anywhere in the window at all. I’ve just reinstalled Chrome and it actually works on there, so I can at least carry on with that in the meantime.


1 Like

Hi @Ben_Hughes

Thanks for sharing that extra information.

I’ve reported this issue to the team so we can investigate further. My initial thought is that the issue is stemming from the current version of Safari you have + older OS as I cannot recreate this on the latest versions.

I’ll post back here when we have more details on the issue. :bowing_man:

That makes a lot of sense. Thanks for reporting it for me, at least I can work on chrome in the meantime.

1 Like

@Ben_Hughes You should be able to upgrade Safari to the latest version without updating your MacOS. One option you can try if you’d like to use Safari is try to upgrade to the latest Safari version (11.1 I believe) and see if this helps resolve the issue.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.